summaryrefslogtreecommitdiff
path: root/django/utils
AgeCommit message (Expand)Author
2016-12-01Fixed #27546 -- Removed hardcoded class names in __repr__() methods.Keda87
2016-11-29Fixed #27555 -- Removed django.utils.functional.lazy_property.Adam Chainz
2016-11-23Cleaned up some __getstate__() docstrings.Tim Graham
2016-11-14Fixed #27463 -- Fixed E741 flake8 warnings.Ramin Farajpour Cami
2016-11-14Fixed E305 flake8 warnings.Ramin Farajpour Cami
2016-11-14Decorated a few functions.Tim Graham
2016-11-07Fixed #27138 -- Restored pre-Python 3.6 behavior of localtime() and make_naiv...Joachim Jablon
2016-11-07Fixed #27454 -- Skipped gettext calls for apps without a locale dir.Carl Meyer
2016-10-31Fixed #27063 -- Prevented i18n_patterns() from using too much of the URL as t...Krzysztof Urbaniak
2016-10-27Fixed #27327 -- Simplified time zone handling by requiring pytz.Tim Graham
2016-10-20Removed note about obsolete Python versionClaude Paroz
2016-10-14Refs #19705 -- Changed gzip modification times to 0.Kevin Christopher Henry
2016-10-12Fixed #19705 -- Set proper headers on conditional Not Modified responses.Kevin Christopher Henry
2016-10-11Added missing roles/options to parse_color_setting()'s docstring.Nick Pope
2016-10-10Fixed #26447 -- Deprecated settings.USE_ETAGS in favor of ConditionalGetMiddl...Denis Cornehl
2016-10-04Fixed #27309 -- Added CallableBool.__hash__().Reto Aebersold
2016-10-01Refs #26940 -- Re-allowed makemessages without settingsClaude Paroz
2016-09-28Fixed #27226 -- Removed patch_response_headers()'s setting of the Last-Modifi...Rinat Khabibiev
2016-09-27Fixed #27271 -- Fixed a crash in runserver logging.Sergey Fursov
2016-09-23Removed unused regexes from django.utils.html.Jon Dufresne
2016-09-17Refs #27025 -- Fixed "invalid escape sequence" warnings in Python 3.6.Tim Graham
2016-09-16Refs #27083 -- Updated conditional header comparison to match RFC 7232.Kevin Christopher Henry
2016-09-16Fixed #27198 -- Made MultiValueDict.getlist() return a new list to prevent mu...Jani Tiainen
2016-09-10Fixed #27083 -- Added support for weak ETags.Kevin Christopher Henry
2016-09-07Refs #26956 -- Allowed is_safe_url() to validate against multiple hostsJon Dufresne
2016-08-31Fixed #25181 -- Added localdate() function to get date in a different time zone.Jon Dufresne
2016-08-31Fixed #27154 -- Allowed comparing CallableBool with bitwise or.Olexander Yermakov
2016-08-25Fixed #27067 -- Deprecated string_concat() in favor of format_lazy().Mattias Loverot
2016-08-24Fixed #26866 -- Added format_lazy functionMattias Loverot
2016-08-19Fixed #26902 -- Allowed is_safe_url() to require an https URL.Przemysław Suliga
2016-08-11Fixed #27034 -- Made makemessages independent of USE_I18NClaude Paroz
2016-08-04Fixed #27020 -- Used a context manager to close files.Ville Skyttä
2016-08-02Fixed #26988 -- Improved/clarified User.is_authenticated/anonymous compatibil...Tim Graham
2016-07-14Fixed #26656 -- Added duration (timedelta) support to DjangoJSONEncoder.Will Hardy
2016-06-22Fixed #25920 -- Added support for non-uniform NUMBER_GROUPING.jasisz
2016-06-17Refs #26601 -- Improved backwards-compatibility of DEP 5 middleware exception...Carl Meyer
2016-06-13Fixed #26746 -- Fixed handling of zero priority in Accept-Language header par...Vytis Banaitis
2016-06-11Fixed #26744 -- Fixed a typo in regex for Accept-Language header parsing.Vytis Banaitis
2016-06-08Fixed #26705 -- Fixed plural versions of languages not supported by Django.Thejaswi Puthraya
2016-06-07Fixed #10107 -- Allowed using mark_safe() as a decorator.Scott Vitale
2016-06-04Fixed #24781 -- Fixed repr() for lazy objects.Chesco Igual
2016-05-30Fixed #26653 -- Made SyndicationFeed.latest_post_date() return time in UTC.Ketan Bhatt
2016-05-28Added RemovedInDjango21WarningTim Graham
2016-05-17Fixed #26601 -- Improved middleware per DEP 0005.Florian Apolloner
2016-05-12Fixed #21231 -- Enforced a max size for GET/POST values read into memory.Andre Cruz
2016-05-10Fixed #24046 -- Deprecated the "escape" half of utils.safestring.Tim Graham
2016-05-10Stopped truncating AdminEmailHandler message subjectsClaude Paroz
2016-05-10Fixed #26580 -- Updated references to obsolete RFC 2822.Vasiliy Faronov
2016-05-03Fixed #26567 -- Updated references to obsolete RFC2616.Vasiliy Faronov
2016-04-20Fixed #26281 -- Added a helpful error message for an invalid format specifier...Marko Benko